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Application Circuit
of Low Noise Op-Amp TC75S67TU
for Current Sensor

Reference Guide
RD161-RGUIDE-01

Overview
This reference guide describes the specifications, board patterns, usage, and characteristics of
the current sensor (hereinafter referred to as the "sensor") using the low-noise operational
amplifier TC75S67TU. A microcontroller can be used to control operations and display results.
Please refer to this section when designing a current sensor using a TC75S67TU.
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1. Introduction
The current sensor described in this reference guide uses a simple-structured shunt resistor as the
current sensing method. In addition to being able to measure currents up to 2 A, we also designed
a GND sense and a ringing detection for current. It can be widely used for a variety of applications,
current sensing for battery-powered devices such as notebook PCs and electronic cigarettes, and
overcurrent protection for home appliances. Arduino is used for the microcontroller to control
operations and to display the results on the computer. The power supply also uses a 5 V DC voltage
supplied by Arduino, so it can be used as a current sensor if there is a Arduino and a personal
computer in addition to this sensor.
To download of the various offer information on this sensor reference design →

Click Here

The components other than the op-amp are also mounted on a compact board size of 20 mm x 20
mm using surface mount, making it easy to use for a variety of applications.
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2. Specifications and Appearance
2.1. Specification
Table 2.1 Current Sensor Circuit Specifications
Item

Specification

I/F

Arduino connectivity

Control method

Control from Arduino and Shield connected PCs

Power supply voltage

Arduino and Shield board feed 5 V

Measured current

Maximum 2 A
RL73H3AR10FTE of TE connectivity

Shunt resistor

100 mΩ, ±1 % accuracy, 1 W@70 °C

On-board operational

Toshiba Device & Storage TC75S67TU

amplifier

2.2. Appearance
20mm

20mm

Top (parts mount side)

Bottom

Fig. 2.1 Current Sensor Appearance
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3. Circuit and Board Pattern
3.1. Circuit Diagram

Fig. 3.1 Current Sensor Circuit Diagram
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3.2. Bill of Materials
Table 3.1 Bill of Materials
Item

Parts

Q’ty

Value

Part
name

Manufacturer

Description

Package
Name

Standard
dimensions
mm (inch)

1

U1

1

-

TC75S67TU

TOSHIBA

Operational
amplifier

SOT-353F

2.0×2.1×0.7

2

C1, C13

2

1800 pF

Ceramic
50 V, ±10 %

1.0×0.5
(0402)

3

C4

1

10 nF

Ceramic
25 V, ±10 %

1.0×0.5
(0402)

4

C5

1

100 nF

Ceramic
16 V, ±10 %

1.0×0.5
(0402)

5

C12,
C14

2

10 μF

Ceramic
25 V, ±10 %

2.0×1.2
(0805)

6

R1, R13

2

20 kΩ

100 mW, ±1 %

1.0×0.5
(0402)

7

R9

1

0Ω

1A

1.0×0.5
(0402)

8

R10

1

100 mΩ

Shunt resistor
1 W, ±1 %

6.4×3.2
(2512)

9

R11,
R12

2

1 kΩ

100 mW, ±1 %

1.0×0.5
(0402)

10

R14

1

100 Ω

100 mW, ±1 %

1.0×0.5
(0402)

11

R15

1

2.4 kΩ

100 mW, ±1 %

1.0×0.5
(0402)

12

R16

1

13

CN2

1

RL73H3A
R10FTE

TE connectivity

1.0×0.5
(0402)
-

110990030
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3.3. Board Pattern Drawing
This board consists of both top and bottom sides. The parts mounting side is top side.
<Top Side (Parts Mounting Side)>

Fig. 3.2 Board Pattern

Fig. 3.3 Substrate Silk
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Fig. 3.4 Substrate Solder
<Bottom Side>

Fig. 3.5 Board Pattern
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Fig. 3.6 Substrate Silk

Fig. 3.7. Substrate Solder
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4. Operation Procedure
4.1. Arduino and Processing
Arduino is a palm-sized one-board microcontroller. The microcontroller is selected as the control
microcontroller for this reference design because it is generally available on the market and can be
easily got, and if the program is transferred once, the sensor can be operated without a PC. Use the
Processing to display the measurement results on the PC-screen.
This reference design provides Arduino operating program and a Processing program that displays
the status of measurements. To run this program, you must install Arduino IDE and Processing 3 on
your PCs. Both software are available free of charge on their official sites. Download the software
and install it on your PC in advance. These software are also needed to edit each program. These
programs are called "sketches" in Arduino, Processing.
Moreover, in the case of Windows10, a display window for result of Processing may not start. In
such a case, it is necessary to change the configuration file of initial value that generated
automatically at the first time start-up of Processing. Since a solution change with PCs, please
implement a suitable solution with reference to Web etc.
Refer to the Commercial Instructions for more information on Arduino and Processing.

4.2. Connecting to Arduino
Fig. 4.1 shows an example of connecting to Arduino.

To PC
Fig. 4.1 Connection to Arduino
Arduino is used with ”seeed studio Base Shield”. The connection port of the base shield to the
sensor is connected A1 terminal. Connect the base shield and the PC with a USB cable.
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4.3. Start and Stop
When the compressed file "RD161-SKETCH-01_E.zip" of the sketch prepared for this sensor is
downloaded from the following link and decompressed in an appropriate place on the PC, the folder
containing the two files "Current_sensor_Arduino.ino" and "Current_sensor.pde" and the usage
convention is created. Save the file as is.
To download sketches →

Click Here

Start the Arduino IDE and select “File” → “Open” to open the saved Current_sensor_Arduino.ino
file. The window shown on the left of Fig. 4.2 opens separately from the window opened at startup.
Select “Sketch” → “Upload” to start compiling the files and write the sketch to the Arduino after
compiling. When writing is completed successfully, a message appears at the bottom of the window.
The Arduino is now ready.

Fig. 4.2 Arduino IDE Window
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Then start the Processing 3. When you start the Processing 3, the window shown in Fig. 4.3 opens.
Click Get Started at the bottom right of the child window. Then, select File → Open to open the saved
Current_sensor.pde file.

Fig. 4.3 Startup window of Processing 3
The window shown in Fig.4.4 opens separately from the window opened at startup. Click the
operation button (red circle) here to open the result display window and start the measurement.

Fig. 4.4 Processing Measurement Start Window
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Click the stop button (red circle in Fig. 4.5) on this screen to finish the measurement. The Result
View window closes and the measurement ends. Then close the open windows sequentially.

Fig. 4. 5 Processing Measuring Completion Window
You can pause the measurement by clicking on the result display window while the measurement
is being performed. At this time, the result display window is not closed and the measurement
waveform remains stopped. To restart the measurement, click on the window again.

4.4. Zero Point Correction Method
TC75S67TU may have input-offset voltages of 0.5 mV, typical, and up to 3 mV according to the
product specification. Since this is the offset voltage multiplied by the gain on the output, a
maximum output offset voltage of 60 mV may be generated with this sensor with a gain setting of
20 times (26 dB), which causes a zero point deviation and causes an error.
For example, if there is an offset voltage of 0.5 mV in terms of input, this corresponds to a
current of 5 mA with a 100 mΩ shunt resistor, so the measurement result will show 0.01 A, even
though no current actually flows.
This zero shift can be corrected by software. This section explains how to correct a zero shift.
This current sensor calculates the current value from the voltage drop of the shunt resistor, but
for the purpose of improving the current detection accuracy around 0 A and GND sensing, the
input terminal has been biased at 200 mV to raise DC voltage. This value is subtracted when
calculating the current value. The zero shift by the offset of the op-amp is compensated by
changing this part.
The relevant part is the 62nd line (Fig. 4.6) of the sketch of Processing prepared in this reference
design.
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Fig. 4.6 Line 62 of Processing Sketch
In the red box shown in Fig. 4.6, the input voltage to Arduino is calculated by counting the LSBs
(Least Significant Bit) of the input A/D converter, and "value" is the result of measuring the output
voltage of the operational amplifier including the offsets. The bottom-up voltage is subtracted from
this point to cancel.
Since Arduino input A/D converter has 10 bits, the voltage VLSB per 1 count of LSB is as follows.
𝑉𝑉𝐿𝐿𝐿𝐿𝐿𝐿 ＝

𝑉𝑉𝐶𝐶𝐶𝐶

210 ー1

=

5
≅ 0.00488 = 4.88 ( 𝑚𝑚𝑚𝑚)
1023

・・・・ (4.1)

The denominator in this equation subtracts 1 from 210, because 0 is the first count.
If the output offset voltage is VOS, the number of offset voltages counted by LSBs (the number
subtracted from "value") x is obtained by the following equation 4.2.
⎡
⎤
𝑉𝑉𝑂𝑂𝑂𝑂 × (210 ー1)
𝑉𝑉𝑂𝑂𝑂𝑂
𝑉𝑉𝑂𝑂𝑂𝑂 × 1023
⎢ 𝑉𝑉𝑂𝑂𝑂𝑂
⎥
𝑥𝑥＝ �
− 0.5� = ⎢
ー0.5⎥ = �
ー0.5� = �
− 0.5� ・・・・ (4.2)
𝑉𝑉
𝑉𝑉𝐶𝐶𝐶𝐶
𝑉𝑉𝐿𝐿𝐿𝐿𝐿𝐿
5
𝐶𝐶𝐶𝐶
(
)
⎢
⎥
⎢ 210 －1
⎥

Since the count number is an integer value that is closest to VOS divided by VLSB, Equation 4.2
performs an operation (ceiling function) that gives the smallest integer that is greater than or
equal to the value obtained by subtracting 0.5 from the result of the division. The symbol “⌈ ⌉” in

the equation indicates the ceiling function.

When there is no offset of the operational amplifier, VOS is 0.2 V. Therefore, the count number at

this time is 41 as shown in the equation 4.3 below.
0.2 × 1023
− 0.5� = ⌈40.92 − 0.5⌉ = 41
𝑥𝑥 = �
5

・・・・ (4.3)

Processing sketches provided in this reference design defaults to 41. When there is a zero point
shift, please make adjustments according to the following. Sketches can be edited and saved on
Processing.
The following explains the procedure by taking the case where zero point misalignment of 0.01 A
occurs as an example.
Since the voltage drop of the shunt resistor (100 mΩ=0.1 Ω) generated by the current equal to
the displayed deviation is considered to be the input-offset voltage VIO of the op-amp, VIO is
assumed to be 1 mV as shown in the equation 4.4.
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𝑉𝑉𝐼𝐼𝐼𝐼 = 0.01 × 0.1 = 0.001 = 1 (𝑚𝑚𝑚𝑚)

・・・・ (4.4)

At this time, the output offset voltage VOS of the op-amp is the voltage which added 0.2 V for a
bottom raising to the voltage which increased VIO 20 times, and is obtained as shown in the
equation 4.5 below.
𝑉𝑉𝑂𝑂𝑂𝑂 = 0.2＋0.001 × 20 = 0.22 (𝑉𝑉)

・・・・ (4.5)

Assign this to the equation 4.2 to calculate the count.
0.22 × 1023
𝑥𝑥 = �
ー0.5� = ⌈45.012 − 0.5⌉＝⌈44.512⌉ = 45
5

Change Processing sketch line 62 (Fig 4.6) as follows:

・・・・ (4.6)

text( "Current : " + nf((float)(value-45)*2500.0/1023.0/1000.0,1,2) +" A", 435, 41);
In Processing sketch of this reference design, the smallest digit of the result display is larger
than the resolution determined by the LSB. Therefore, the zero point deviation may not be
eliminated. If this happens, adjust the value one by one while viewing the actual result display.

4.5. Precautions for Evaluation


The resolution of this current sensor is approximately 2.4 mA.



Although the shunt resistor of the current sensor is set to a minute resistance value in
consideration of heat generation, it may become hot if the current continues to flow for a long
time. Be careful not to touch the board directly in such a case as this may cause burns.



The current sensor in this guide is designed to be connected to the low (GND) side of the load
with the shunt resistor's Low (-) terminal grounded. It cannot be used by connecting to the
high (power supply) side.



When this current sensor is connected, it may affect the start and stop sequence of the
equipment that is the load.
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5. Current Measurement Results
In Processing, the current calculated from the measured value is displayed.
A measurement result display window when a DC power supply is connected to shunt resistor
and turned on is shown below.
Fig.5.1 shows a waveform when current is set as 0.10 A, Fig.5.2 shows a waveform when it is
set as 1.50 A. The displayed current value shows the value after power ON.

Setting current : 0.10 A
Measurement results of
the current sensor

Power ON

Fig. 5.1 Measurement Result Indication by Processing (1)

Measurement results of

Setting current : 1.50 A

the current sensor

Power ON

Fig. 5.2 Measurement Result Indication by Processing (2)
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Terms of Use
This terms of use is made between Toshiba Electronic Devices and Storage Corporation (“We”) and customers who
use documents and data that are consulted to design electronics applications on which our semiconductor devices
are mounted (“this Reference Design”). Customers shall comply with this terms of use. Please note that it is assumed
that customers agree to any and all this terms of use if customers download this Reference Design. We may, at its
sole and exclusive discretion, change, alter, modify, add, and/or remove any part of this terms of use at any time
without any prior notice. We may terminate this terms of use at any time and for any reason. Upon termination of
this terms of use, customers shall destroy this Reference Design. In the event of any breach thereof by customers,
customers shall destroy this Reference Design, and furnish us a written confirmation to prove such destruction.
1. Restrictions on usage
1. This Reference Design is provided solely as reference data for designing electronics applications. Customers shall
not use this Reference Design for any other purpose, including without limitation, verification of reliability.
2. This Reference Design is for customer's own use and not for sale, lease or other transfer.
3. Customers shall not use this Reference Design for evaluation in high or low temperature, high humidity, or high
electromagnetic environments.
4. This Reference Design shall not be used for or incorporated into any products or systems whose manufacture,
use, or sale is prohibited under any applicable laws or regulations.
2. Limitations
1. We reserve the right to make changes to this Reference Design without notice.
2. This Reference Design should be treated as a reference only. We are not responsible for any incorrect or
incomplete data and information.
3. Semiconductor devices can malfunction or fail. When designing electronics applications by referring to this
Reference Design, customers are responsible for complying with safety standards and for providing adequate designs
and safeguards for their hardware, software and systems which minimize risk and avoid situations in which a
malfunction or failure of semiconductor devices could cause loss of human life, bodily injury or damage to property,
including data loss or corruption. Customers must also refer to and comply with the latest versions of all relevant our
information, including without limitation, specifications, data sheets and application notes for semiconductor devices,
as well as the precautions and conditions set forth in the "Semiconductor Reliability Handbook".
4. When designing electronics applications by referring to this Reference Design, customers must evaluate the whole
system adequately. Customers are solely responsible for all aspects of their own product design or applications. WE
ASSUME NO LIABILITY FOR CUSTOMERS' PRODUCT DESIGN OR APPLICATIONS.
5. No responsibility is assumed by us for any infringement of patents or any other intellectual property rights of
third parties that may result from the use of this Reference Design. No license to any intellectual property right is
granted by this terms of use, whether express or implied, by estoppel or otherwise.
6. THIS REFERENCE DESIGN IS PROVIDED "AS IS". WE (a) ASSUME NO LIABILITY WHATSOEVER, INCLUDING
WITHOUT LIMITATION, INDIRECT, CONSEQUENTIAL, SPECIAL, OR INCIDENTAL DAMAGES OR LOSS, INCLUDING
WITHOUT LIMITATION, LOSS OF PROFITS, LOSS OF OPPORTUNITIES, BUSINESS INTERRUPTION AND LOSS OF
DATA, AND (b) DISCLAIM ANY AND ALL EXPRESS OR IMPLIED WARRANTIES AND CONDITIONS RELATED TO THIS
REFERENCE DESIGN, INCLUDING WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE, ACCURACY OF INFORMATION, OR NONINFRINGEMENT.
3. Export Control
Customers shall not use or otherwise make available this Reference Design for any military purposes, including
without limitation, for the design, development, use, stockpiling or manufacturing of nuclear, chemical, or biological
weapons or missile technology products (mass destruction weapons). This Reference Design may be controlled under
the applicable export laws and regulations including, without limitation, the Japanese Foreign Exchange and Foreign
Trade Law and the U.S. Export Administration Regulations. Export and re-export of this Reference Design are strictly
prohibited except in compliance with all applicable export laws and regulations.
4. Governing Laws
This terms of use shall be governed and construed by laws of Japan.
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